1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Sébastien Luttringer
3 # Contributor: Lawrence Lee <valheru@facticius.net>
4 # Contributor: Phillip Marvin <phillip.marvin@gmail.com>
5 # Contributor: keystone <phillip.marvin@gmail.com>
10 pkgdesc='Portable and efficient C programming interface (API) to determine the call-chain of a program'
12 url='https://www.nongnu.org/libunwind/'
15 makedepends=('texlive-core')
17 source=("https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
18 sha512sums=('1d17dfb14f99a894a6cda256caf9ec481c14068aaf8f3a85fa3befa7c7cca7fca0f544a91a3a7c2f2fc55bab19b06a67ca79f55ac9081151d94478c7f611f8f7'
20 validpgpkeys=('5C96BDEAF5F47FB02BD4F6B965D98560914F3F48' # Arun Sharma
21 '1675C8DA2EF907FB116EB709EC52B396E6874AF2' # Dave Watson
22 '75D2CFC56CC2E935A4143297015A268A17D55FA4') # Dave Watson
26 ./configure --prefix=/usr
27 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
33 # This function is ``supposed'' to fail. Upstream know, but haven't fixed it.
39 make DESTDIR="$pkgdir" install
42 # vim:set sw=2 sts=-1 et: