archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libusb-compat / repos / extra-x86_64 / PKGBUILD
blob9e39c296e28fc85b6e5e244d2173ce030b95c1ef
1 # Maintainer:
2 # Contributor: Tom Gundersen <teg@jklm.no>
3 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
4 # Contributor: arjan <arjan@archlinux.org>
6 pkgname=libusb-compat
7 pkgver=0.1.8
8 pkgrel=1
9 pkgdesc="Library to enable user space application programs to communicate with USB devices"
10 arch=('x86_64')
11 url="http://libusb.sourceforge.net/"
12 license=('LGPL')
13 depends=('libusb' 'sh')
14 source=("https://github.com/libusb/libusb-compat-0.1/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
15 sha256sums=('f79dcc3b2c2ef4141e5300faf71519badde85d4ac87fd3372d2b88bba8af05dc')
17 prepare() {
18   cd ${pkgname}-${pkgver}
19   ./autogen.sh
22 build() {
23   cd ${pkgname}-${pkgver}
24   ./configure --prefix=/usr --disable-static
25   make
28 package() {
29   cd ${pkgname}-${pkgver}
30   make DESTDIR="${pkgdir}" install