archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libusbmuxd / repos / extra-x86_64 / PKGBUILD
blob0d48fd904eb509ac8feefd86711684aad2d05087
1 # Contributor: Ionut Biru <ibiru@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Gabriel Martinez < reitaka at gmail dot com >
5 pkgname=libusbmuxd
6 pkgver=2.0.2
7 pkgrel=2
8 pkgdesc="USB Multiplex Daemon"
9 url="https://marcansoft.com/blog/iphonelinux/usbmuxd/"
10 arch=(x86_64)
11 license=(
12   GPL2
13   LGPL2.1
15 depends=(
16   libplist
17   libusb
19 makedepends=(git)
20 conflicts=('usbmuxd<1.0.9')
21 _commit=ce98c346b7c1dc2a21faea4fd3f32c88e27ca2af
22 source=("git+https://github.com/libimobiledevice/libusbmuxd#commit=$_commit")
23 b2sums=('SKIP')
25 pkgver() {
26   cd $pkgname
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 check() {
31   cd $pkgname
32   make check
35 prepare() {
36   cd $pkgname
37   NOCONFIGURE=1 ./autogen.sh
40 build() {
41   cd $pkgname
42   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
43   make
46 package() {
47   cd $pkgname
48   make DESTDIR="${pkgdir}" install
51 # vim:set sw=2 sts=-1 et: