archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libvpx / repos / extra-x86_64 / PKGBUILD
blob45a8199fbc59b95043da4dbcb40da22c6bae1d1e
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
5 pkgname=libvpx
6 pkgver=1.13.0
7 pkgrel=1
8 pkgdesc='VP8 and VP9 codec'
9 arch=(x86_64)
10 url=https://www.webmproject.org/
11 license=(BSD)
12 depends=(gcc-libs)
13 makedepends=(
14   git
15   nasm
17 provides=(libvpx.so)
18 _tag=d6eb9696aa72473c1a11d34d928d35a3acc0c9a9
19 source=(git+https://chromium.googlesource.com/webm/libvpx#tag=${_tag})
20 sha256sums=(SKIP)
22 pkgver() {
23   cd libvpx
25   git describe --tags | sed 's/^v//'
28 build() {
29   cd libvpx
31   CFLAGS+=' -ffat-lto-objects'
32   CXXFLAGS+=' -ffat-lto-objects'
34   ./configure \
35     --prefix=/usr \
36     --disable-install-docs \
37     --disable-install-srcs \
38     --disable-unit-tests \
39     --enable-pic \
40     --enable-postproc \
41     --enable-runtime-cpu-detect \
42     --enable-shared \
43     --enable-vp8 \
44     --enable-vp9 \
45     --enable-vp9-highbitdepth \
46     --enable-vp9-temporal-denoising
47   make
50 package() {
51   cd libvpx
53   make DIST_DIR="${pkgdir}"/usr install
54   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/libvpx/
57 # vim:set sw=2 sts=-1 et: