archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libxfce4ui / repos / extra-x86_64 / PKGBUILD
bloba6e0ce5b2ec236762a4700267ce832afb58f010f
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Xavier Devlamynck <magicrhesus@ouranos.be>
4 pkgname=libxfce4ui
5 pkgver=4.18.3
6 pkgrel=1
7 pkgdesc="Widgets library for the Xfce desktop environment"
8 arch=('x86_64')
9 url="https://www.xfce.org/"
10 license=('GPL2')
11 depends=('libxfce4util' 'gtk3' 'xfconf' 'libsm' 'startup-notification'
12          'libgtop' 'libepoxy' 'hicolor-icon-theme')
13 makedepends=('intltool' 'gobject-introspection' 'vala')
14 source=(https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
15 sha256sums=('afa3a46eeed3ab612d2f7e1308edaf5819f6c33ccc16c13080efabd58f010abd')
17 build() {
18   cd $pkgname-$pkgver
20   ./configure \
21     --prefix=/usr \
22     --sysconfdir=/etc \
23     --localstatedir=/var \
24     --disable-debug \
25     --with-vendor-info='Arch Linux'
26   make
29 package() {
30   cd $pkgname-$pkgver
31   make DESTDIR="$pkgdir" install
34 # vim:set ts=2 sw=2 et: