archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libzapojit / trunk / PKGBUILD
blobbd5a72b1cb1669f9369233741f8ce65bf532ccb5
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
3 pkgname=libzapojit
4 pkgver=0.0.3+14+g2dace3f
5 pkgrel=2
6 pkgdesc="GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs"
7 url="https://wiki.gnome.org/Projects/Zapojit"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(libsoup gnome-online-accounts)
11 makedepends=(intltool gobject-introspection git gtk-doc autoconf-archive)
12 _commit=2dace3ffcd9ca60c4adb406cf0e8077cd396f722  # master
13 source=("git+https://gitlab.gnome.org/GNOME/libzapojit.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 prepare() {
22   cd $pkgname
23   NOCONFIGURE=1 ./autogen.sh
26 build() {
27   cd $pkgname
28   ./configure --prefix=/usr --disable-static --enable-gtk-doc
29   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
30   make
33 package() {
34   cd $pkgname
35   make DESTDIR="$pkgdir" install