1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
7 pkgdesc="Next generation, high-performance debugger"
9 url="https://lldb.llvm.org/"
10 license=('custom:Apache 2.0 with LLVM Exception')
11 depends=('llvm-libs' 'clang' 'python' 'python-six')
12 makedepends=('llvm' 'cmake' 'ninja' 'swig' 'python-sphinx')
13 _source_base=https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver
14 source=($_source_base/lldb-$pkgver.src.tar.xz{,.sig}
15 $_source_base/cmake-$pkgver.src.tar.xz{,.sig})
16 sha256sums=('f64d5533661c766a2ff97062af5a0523b9e2cd56aa3d95d9624c418e120d1427'
18 '8986f29b634fdaa9862eedda78513969fe9788301c9f2d938f4c10a3e7a3e7ea'
20 validpgpkeys=('474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
21 'D574BD5D1D0E98895E3BF90044F2485E45D59042') # Tobias Hieta <tobias@hieta.se>
24 mv cmake{-$pkgver.src,}
30 cd lldb-$pkgver.src/build
34 -DCMAKE_BUILD_TYPE=Release
35 -DCMAKE_INSTALL_PREFIX=/usr
37 -DCLANG_LINK_CLANG_DYLIB=ON
38 -DLLDB_USE_SYSTEM_SIX=1
39 -DLLVM_ENABLE_SPHINX=ON
40 -DLLVM_LINK_LLVM_DYLIB=ON
42 cmake .. "${cmake_args[@]}"
43 ninja all docs-lldb-man
47 cd lldb-$pkgver.src/build
49 DESTDIR="$pkgdir" ninja install
50 install -Dm644 ../LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
52 install -Dm644 docs/man/lldb.1 "$pkgdir/usr/share/man/man1/lldb.1"
54 # Compile Python scripts
55 python3 -m compileall "$pkgdir"
56 python3 -O -m compileall "$pkgdir"
57 python3 -OO -m compileall "$pkgdir"
60 # vim:set ts=2 sw=2 et: