1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
6 pkgdesc="Rotates system logs automatically"
8 url="https://github.com/logrotate/logrotate"
10 depends=('popt' 'gzip' 'acl')
11 backup=('etc/logrotate.conf')
12 source=("https://github.com/logrotate/logrotate/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"{,.asc}
14 sha256sums=('8fa12015e3b8415c121fc9c0ca53aa872f7b0702f543afda7e32b6c4900f6516'
16 '42e289081a4d6b144c89dbfc49bde7a01b383055bf90a05a764f8c3dee25a6ce')
17 validpgpkeys=('992A96E075056E79CD8214F9873DB37572A37B36')
20 cd "$srcdir/${pkgname}-${pkgver}"
25 --mandir=/usr/share/man \
26 --with-compress-command=/usr/bin/gzip \
27 --with-uncompress-command=/usr/bin/gunzip \
28 --with-default-mail-command=/usr/bin/mail \
34 cd "$srcdir/${pkgname}-${pkgver}"
40 cd "$srcdir/${pkgname}-${pkgver}"
42 make DESTDIR="$pkgdir" install
44 install -dm755 "$pkgdir/etc/logrotate.d"
45 install -Dm644 "$srcdir/logrotate.conf" "$pkgdir/etc/logrotate.conf"
47 install -D -m644 examples/logrotate.timer "${pkgdir}/usr/lib/systemd/system/logrotate.timer"
48 install -D -m644 examples/logrotate.service "${pkgdir}/usr/lib/systemd/system/logrotate.service"
49 install -d -m755 "$pkgdir/usr/lib/systemd/system/timers.target.wants"
50 ln -s ../logrotate.timer "$pkgdir/usr/lib/systemd/system/timers.target.wants/logrotate.timer"