archrelease: copy trunk to extra-x86_64
[arch-packages.git] / minuet / repos / extra-x86_64 / PKGBUILD
blobbed6d42d09f97c653fe070e81b64e9b0b9e22e4a
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=minuet
4 pkgver=23.04.1
5 pkgrel=1
6 pkgdesc='A KDE Software for Music Education'
7 url='https://apps.kde.org/minuet/'
8 arch=(x86_64)
9 license=(GPL LGPL FDL)
10 groups=(kde-applications kde-education)
11 depends=(fluidsynth qt5-quickcontrols2 qt5-svg ki18n kcrash hicolor-icon-theme)
12 makedepends=(extra-cmake-modules kdoctools)
13 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('48cee2a16053924c6d3124e1586f75fb6722486b06e2b1653b42911534b3461f'
15             'SKIP')
16 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
17               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
18               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build