1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
7 pkgdesc="Common build files of the C++ bindings"
8 url="https://www.gtkmm.org/"
10 depends=(graphviz doxygen gtk-doc libsigc++-docs perl-xml-parser)
11 makedepends=(libsigc++ git meson)
13 _commit=16af4937218061076c18816f749242b4c488383b # tags/1.0.5^0
14 source=("git+https://gitlab.gnome.org/GNOME/mm-common.git#commit=$_commit"
15 https://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/libstdc++.tag)
17 'dfb6521cb807fc827c34bcd47dbcf2f7564b2fc1b6014ebb13bed349ddf55af0')
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 cp ../libstdc++.tag doctags
30 arch-meson $pkgname build
31 meson compile -C build
35 meson test -C build --print-errorlogs
39 meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 sts=-1 et: