1 # Maintainer: Jan de Groot <jgc@archlinux.org>
4 pkgname=('musepack-tools' 'libmpcdec')
9 pkgdesc="MusePack commandline utilities and decoder library"
11 url="http://musepack.net/"
12 license=('LGPL' 'custom')
14 makedepends=('libreplaygain' 'libcue')
15 source=(http://files.musepack.net/source/musepack_src_r${_rel}.tar.gz
16 01_am-maintainer-mode.patch
21 1001_missing_extern_kw.patch
22 add_subdir-objects.patch)
23 md5sums=('754d67be67f713e54baf70fcfdb2817e'
24 '6da8b85474fe2fcf55d4a3cfa68ddd8e'
25 '57f9c8f1858008ac14b0d3cf2b7cf2dc'
26 'b0b499dcdbb87b53eaf6db67e1592b51'
27 'b1e5b6f8cb3c5b77e4438971c7a20797'
28 '661783cf9ad4fed435d1c055b74b680b'
29 'e7ab0ee8b1753d5986a2cefe233cc99a'
30 'dc3e62894bf81dabd4451646b183a2e4')
33 cd musepack_src_r${_rel}
34 patch -Np1 -i ../01_am-maintainer-mode.patch
35 patch -Np1 -i ../02_link-libm.patch
36 patch -Np1 -i ../03_mpcchap.patch
37 patch -Np1 -i ../04_link-order.patch
38 patch -Np1 -i ../05_visibility.patch
39 patch -Np1 -i ../1001_missing_extern_kw.patch
40 patch -Np1 -i ../add_subdir-objects.patch
41 mv configure.in configure.ac
45 cd musepack_src_r${_rel}
47 ./configure --prefix=/usr --enable-mpcchap
52 pkgdesc="MusePack decoding library"
55 cd musepack_src_r${_rel}
56 make -C include DESTDIR="${pkgdir}" install
57 make -C libmpcdec DESTDIR="${pkgdir}" install
58 install -Dm644 libmpcdec/COPYING ${pkgdir}/usr/share/licenses/libmpcdec/COPYING
61 package_musepack-tools() {
62 depends=('libcue' 'libreplaygain' 'libmpcdec>=1:0.1+r475')
63 pkgdesc="MusePack commandline tools"
67 cd musepack_src_r${_rel}
68 make DESTDIR="${pkgdir}" install
69 make -C libmpcdec DESTDIR="${pkgdir}" uninstall
70 make -C include DESTDIR="${pkgdir}" uninstall