1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: tobias [tobias [at] archlinux.org]
8 pkgdesc="Small but very powerful text-based mail client"
10 url="http://www.mutt.org/"
34 'perl: for smime_keys'
35 'python: for experimental mutt_oath2.py'
36 'smtp-forwarder: to send mail'
38 backup=(etc/$pkgname/Muttrc)
39 install=$pkgname.install
40 source=(https://bitbucket.org/$pkgname/$pkgname/downloads/$pkgname-$pkgver.tar.gz{,.asc})
41 sha512sums=('6db0009163b31425dafe7b6e38374a623f1fd057daf57baaebe18be6d42e5a0ce7087a41bc5e2411f4fbe144497a43682c480754b51108952c7dd16b9294192f'
43 b2sums=('d6892f49520b4fd73d7d0d04119b4f05828d76a4be4b55a8dbc585ef817d4455c9b9a93158d31e0699f011023de524355930d4acff3b9454982da0042c54db22'
45 validpgpkeys=('8975A9B33AA37910385C5308ADEF768480316BDA') # Kevin J. McCarthy <kevin@8t8.us>
53 local configure_options=(
55 --sysconfdir=/etc/$pkgname
74 ./configure "${configure_options[@]}"
82 krb5 libgssapi_krb5.so
85 ncurses libncursesw.so
89 make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
90 # we backup /etc/mutt/Muttrc and don't need another copy
91 rm -v "$pkgdir/etc/$pkgname/Muttrc.dist"
92 # a more comprehensive list of mime types is provided by mailcap in /etc/mime.types
93 rm -v "$pkgdir/etc/$pkgname/mime.types"{,.dist}
94 ln -sv ../mime.types "$pkgdir/etc/$pkgname/mime.types"