1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
3 # Contributor: Juergen Hoetzel <juergen@archlinux.org>
8 pkgdesc="HTTP and WebDAV client library with a C interface"
10 url="https://notroj.github.io/neon/"
11 license=('GPL' 'LGPL')
12 depends=('krb5' 'expat' 'ca-certificates' 'zlib')
13 makedepends=('xmlto' 'docbook-xsl')
14 options=('libtool') # FS#16067
15 source=(https://notroj.github.io/neon/$pkgname-$pkgver.tar.gz)
16 sha512sums=('97a067fcea6156e2d5cf981e8d8fc9b0a709b8175bc8061a1f254bff7b11a27fdafc5e8425665523e917133084ea3a11e11de7c1210a8d2eb3f6b1cca26ea844')
17 validpgpkeys=('190555472DCC589BEF01609C608A86DF9833CC49') # Joe Orton
20 cd ${pkgname}-${pkgver}
21 ./configure --prefix=/usr \
26 --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
27 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
32 cd ${pkgname}-${pkgver}
33 make DESTDIR="${pkgdir}" install