archrelease: copy trunk to extra-x86_64
[arch-packages.git] / numactl / repos / community-x86_64 / PKGBUILD
blobc562e6d9c77e17fc2e07a4d5d19f07227a83e699
1 # Maintainer: David Runge <dave@sleepmap.de>
2 # Contributor: Dan McGee <dan@archlinux.org>
3 # Contributor: Florian Zeitz <florob at babelmonkeys dot de>
5 pkgname=numactl
6 pkgver=2.0.12
7 pkgrel=3
8 pkgdesc="Simple NUMA policy support"
9 arch=('x86_64')
10 url="http://oss.sgi.com/projects/libnuma/"
11 license=('LGPL2.1' 'GPL2')
12 depends=('perl')
13 provides=('libnuma.so')
14 source=("https://github.com/numactl/numactl/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
15 sha512sums=('316b10f50e6eee4cee9cf191f19381ec4a61980354eec3f9fe43fef21465bee28a82adeb9c235d4877e82950ccd14c9473b79fd1e2f5a7f598ec2fac230780ff')
17 prepare(){
18   cd "${pkgname}-${pkgver}"
19   autoreconf -vfi
22 build() {
23   cd "${pkgname}-${pkgver}"
24   ./configure --prefix=/usr
25   make
28 check() {
29   cd "${pkgname}-${pkgver}"
30   make -k test || msg "Tests known to fail depending on system load."
33 package() {
34   cd "${pkgname}-${pkgver}"
35   make DESTDIR="$pkgdir" install
36   # move_pages(2) is provided by man-pages and is more up-to-date there anyway
37   rm -rf "$pkgdir/usr/share/man/man2"
38   install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"