1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Armin K. <krejzi at email dot com>
7 pkgdesc="Library for binding to C libraries using pure OCaml"
9 url="https://github.com/ocamllabs/ocaml-ctypes"
11 depends=('ocaml' 'libffi' 'ocaml-integers' 'ocaml-bigarray-compat')
12 makedepends=('ocaml-findlib' 'ocaml-compiler-libs')
13 options=('!strip' '!makeflags')
14 source=($pkgname-$pkgver.tar.gz::https://github.com/ocamllabs/ocaml-ctypes/archive/$pkgver.tar.gz)
15 sha512sums=('99cdc77e5283b26fb8f00376f9fe87f84809f533544409036c622ef3bdeb4b6640ece1976da4ef5f4e7dff0ab5a8dd2994ea939fb8a2832d22579b8e854ee55e')
18 cd "$srcdir/$pkgname-$pkgver"
23 cd "$srcdir/$pkgname-$pkgver"
25 local _destdir="$pkgdir$(ocamlfind printconf destdir)"
26 install -d "$_destdir/stublibs"
28 make OCAMLFIND_DESTDIR="$_destdir" install
30 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
33 # vim:set ts=2 sw=2 et: