archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ocaml-result / trunk / PKGBUILD
blob9320a879b377921cc975a59fa1e17aa4929ecbed
1 # Maintainer: Jürgen Hötzel <juergen@archlinux.org>
3 _pkgname=result
4 pkgname=ocaml-${_pkgname}
5 pkgver=1.5
6 pkgrel=8
7 pkgdesc="Compatibility Result module"
8 arch=('i686' 'x86_64' 'armv7h')
9 url="https://github.com/janestreet/result"
10 license=('BSD')
11 depends=('ocaml')
12 makedepends=('ocaml-findlib' 'dune')
13 options=('!strip')
14 source=("https://github.com/janestreet/result/archive/${pkgver}.tar.gz")
15 sha256sums=('1072a8b0b35bd6df939c0670add33027f981e4f69a53233cb006b442fa12af30')
19 build() {
20   cd "${srcdir}/${_pkgname}-${pkgver}"
21   dune build
25 package() {
26   cd "${srcdir}/${_pkgname}-${pkgver}"
28   install -dm755 "${pkgdir}$(ocamlfind printconf destdir)"
29   dune install --prefix "${pkgdir}/usr" \
30     --libdir "${pkgdir}$(ocamlfind printconf destdir)"
32   install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
33   mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"