archrelease: copy trunk to extra-x86_64
[arch-packages.git] / openresolv / trunk / PKGBUILD
blob4f1523ed68a7315c0cb94d7fd58645ff0bf74d08
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ignacio Galmarino <igalmarino@gmail.com>
4 pkgname=openresolv
5 pkgver=3.13.1
6 pkgrel=1
7 pkgdesc="resolv.conf management framework (resolvconf)"
8 url="https://roy.marples.name/projects/openresolv"
9 arch=(any)
10 license=(custom:BSD)
11 provides=(resolvconf)
12 depends=(bash)
13 makedepends=(
14   git
15   systemd
17 backup=(etc/resolvconf.conf)
18 _commit=1afa8e2c1c7bdd5362afb2cc482e85fb01cf5f6d  # tags/v3.13.1^0
19 source=("git+https://github.com/NetworkConfiguration/openresolv#commit=$_commit")
20 b2sums=('SKIP')
22 pkgver() {
23   cd $pkgname
24   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
27 prepare() {
28   cd $pkgname
31 build() {
32   local configure_options=(
33     --prefix=/usr
34     --sysconfdir=/etc
35     --libexecdir=/usr/lib/resolvconf
36     --sbindir=/usr/bin
37   )
39   cd $pkgname
40   ./configure "${configure_options[@]}"
41   make
44 package() {
45   cd $pkgname
46   make DESTDIR="$pkgdir" install
47   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE
50 # vim:set sw=2 sts=-1 et: