1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="Proxy configuration daemon"
8 url="https://git.kernel.org/pub/scm/network/connman/pacrunner.git"
10 depends=(glib2 dbus curl duktape)
13 _commit=bb888a1f99cc05d63bd61b65cad7026feea92a4e # tags/0.19^0
14 source=("git+https://git.kernel.org/pub/scm/network/connman/pacrunner.git#commit=$_commit"
17 '2cbb148bc7cd72230a1aa465c806260eb0fc1dd47d8663b2b48d25cc29622d02')
21 git describe --tags | sed 's/-/+/g'
27 # Use our system duktape
28 git apply -3 ../duktape-shared.diff
38 --localstatedir=/var \
40 --libexecdir=/usr/lib \
41 --with-dbusconfdir=/usr/share \
50 make DESTDIR="$pkgdir" install
52 install -Dm644 /dev/stdin "$pkgdir/usr/lib/systemd/system/pacrunner.service" <<END
54 Description=Proxy configuration daemon
61 ExecStart=/usr/bin/pacrunner
64 WantedBy=multi-user.target
67 install -Dm644 /dev/stdin "$pkgdir/usr/share/dbus-1/system-services/org.pacrunner.service" <<END
70 Exec=/usr/bin/pacrunner
72 SystemdService=pacrunner.service
76 # vim:set sw=2 sts=-1 et: