archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pacrunner / repos / extra-x86_64 / PKGBUILD
blobbe8df487991d9787b2e0dc7a799e9910c3c0e63c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=pacrunner
4 pkgver=0.19
5 pkgrel=2
6 pkgdesc="Proxy configuration daemon"
7 arch=(x86_64)
8 url="https://git.kernel.org/pub/scm/network/connman/pacrunner.git"
9 license=(GPL2 LGPL2.1)
10 depends=(glib2 dbus curl duktape)
11 makedepends=(git)
12 options=(debug)
13 _commit=bb888a1f99cc05d63bd61b65cad7026feea92a4e  # tags/0.19^0
14 source=("git+https://git.kernel.org/pub/scm/network/connman/pacrunner.git#commit=$_commit"
15         duktape-shared.diff)
16 sha256sums=('SKIP'
17             '2cbb148bc7cd72230a1aa465c806260eb0fc1dd47d8663b2b48d25cc29622d02')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
27   # Use our system duktape
28   git apply -3 ../duktape-shared.diff
30   ./bootstrap
33 build() {
34   cd $pkgname
35   ./configure \
36     --prefix=/usr \
37     --sysconfdir=/etc \
38     --localstatedir=/var \
39     --sbindir=/usr/bin \
40     --libexecdir=/usr/lib \
41     --with-dbusconfdir=/usr/share \
42     --enable-pie \
43     --enable-duktape \
44     --enable-curl
45   make
48 package() {
49   cd $pkgname
50   make DESTDIR="$pkgdir" install
52   install -Dm644 /dev/stdin "$pkgdir/usr/lib/systemd/system/pacrunner.service" <<END
53 [Unit]
54 Description=Proxy configuration daemon
55 Before=network.target
56 Wants=network.target
58 [Service]
59 Type=dbus
60 BusName=org.pacrunner
61 ExecStart=/usr/bin/pacrunner
63 [Install]
64 WantedBy=multi-user.target
65 END
67   install -Dm644 /dev/stdin "$pkgdir/usr/share/dbus-1/system-services/org.pacrunner.service" <<END
68 [D-BUS Service]
69 Name=org.pacrunner
70 Exec=/usr/bin/pacrunner
71 User=root
72 SystemdService=pacrunner.service
73 END
76 # vim:set sw=2 sts=-1 et: