1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="Proxy configuration daemon"
8 url="https://git.kernel.org/pub/scm/network/connman/pacrunner.git"
10 depends=(glib2 dbus curl duktape)
12 _commit=bb888a1f99cc05d63bd61b65cad7026feea92a4e # tags/0.19^0
13 source=("git+https://git.kernel.org/pub/scm/network/connman/pacrunner.git#commit=$_commit"
16 '2cbb148bc7cd72230a1aa465c806260eb0fc1dd47d8663b2b48d25cc29622d02')
20 git describe --tags | sed 's/-/+/g'
26 # Use our system duktape
27 git apply -3 ../duktape-shared.diff
37 --localstatedir=/var \
39 --libexecdir=/usr/lib \
40 --with-dbusconfdir=/usr/share \
49 make DESTDIR="$pkgdir" install
51 install -Dm644 /dev/stdin "$pkgdir/usr/lib/systemd/system/pacrunner.service" <<END
53 Description=Proxy configuration daemon
60 ExecStart=/usr/bin/pacrunner
63 WantedBy=multi-user.target
66 install -Dm644 /dev/stdin "$pkgdir/usr/share/dbus-1/system-services/org.pacrunner.service" <<END
69 Exec=/usr/bin/pacrunner
71 SystemdService=pacrunner.service
75 # vim:set sw=2 sts=-1 et: