archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pacrunner / trunk / PKGBUILD
blob7787501af6dbd68acdd85ab2eafd862a9ce639ea
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=pacrunner
4 pkgver=0.19
5 pkgrel=2
6 pkgdesc="Proxy configuration daemon"
7 arch=(x86_64)
8 url="https://git.kernel.org/pub/scm/network/connman/pacrunner.git"
9 license=(GPL2 LGPL2.1)
10 depends=(glib2 dbus curl duktape)
11 makedepends=(git)
12 _commit=bb888a1f99cc05d63bd61b65cad7026feea92a4e  # tags/0.19^0
13 source=("git+https://git.kernel.org/pub/scm/network/connman/pacrunner.git#commit=$_commit"
14         duktape-shared.diff)
15 sha256sums=('SKIP'
16             '2cbb148bc7cd72230a1aa465c806260eb0fc1dd47d8663b2b48d25cc29622d02')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
26   # Use our system duktape
27   git apply -3 ../duktape-shared.diff
29   ./bootstrap
32 build() {
33   cd $pkgname
34   ./configure \
35     --prefix=/usr \
36     --sysconfdir=/etc \
37     --localstatedir=/var \
38     --sbindir=/usr/bin \
39     --libexecdir=/usr/lib \
40     --with-dbusconfdir=/usr/share \
41     --enable-pie \
42     --enable-duktape \
43     --enable-curl
44   make
47 package() {
48   cd $pkgname
49   make DESTDIR="$pkgdir" install
51   install -Dm644 /dev/stdin "$pkgdir/usr/lib/systemd/system/pacrunner.service" <<END
52 [Unit]
53 Description=Proxy configuration daemon
54 Before=network.target
55 Wants=network.target
57 [Service]
58 Type=dbus
59 BusName=org.pacrunner
60 ExecStart=/usr/bin/pacrunner
62 [Install]
63 WantedBy=multi-user.target
64 END
66   install -Dm644 /dev/stdin "$pkgdir/usr/share/dbus-1/system-services/org.pacrunner.service" <<END
67 [D-BUS Service]
68 Name=org.pacrunner
69 Exec=/usr/bin/pacrunner
70 User=root
71 SystemdService=pacrunner.service
72 END
75 # vim:set sw=2 sts=-1 et: