archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pango / trunk / PKGBUILD
blob8a14ff7b040fa66e39c2dba37c069505c03329bc
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=pango
5 pkgname=(
6   pango
7   pango-docs
9 pkgver=1.50.14
10 pkgrel=1
11 epoch=1
12 pkgdesc="A library for layout and rendering of text"
13 url="https://www.pango.org/"
14 arch=(x86_64)
15 license=(LGPL)
16 depends=(
17   cairo
18   fribidi
19   harfbuzz
20   libthai
21   libxft
23 makedepends=(
24   gi-docgen
25   git
26   gobject-introspection
27   help2man
28   meson
30 _commit=25c27f452294f84044d5cc9f23b637193c7b4421  # tags/1.50.14^0
31 source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit")
32 b2sums=('SKIP')
34 pkgver() {
35   cd pango
36   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
39 prepare() {
40   cd pango
43 build() {
44   local meson_options=(
45     -D gtk_doc=true
46   )
48   arch-meson pango build "${meson_options[@]}"
49   meson compile -C build
52 # not running checks: validation breaks when deps
53 # (especially harfbuzz) don't match upstream CI
55 package_pango() {
56   provides=(libpango{,cairo,ft2,xft}-1.0.so)
58   meson install -C build --destdir "$pkgdir"
60   mkdir -p doc/usr/share
61   mv {"$pkgdir",doc}/usr/share/doc
64 package_pango-docs() {
65   pkgdesc+=" (documentation)"
66   depends=()
68   mv doc/* "$pkgdir"
71 # vim:set sw=2 sts=-1 et: