1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=(pangomm pangomm-docs)
8 pkgdesc="C++ bindings for Pango"
9 url="https://www.gtkmm.org/"
12 depends=(pango glibmm cairomm)
13 makedepends=(git meson mm-common glibmm-docs cairomm-docs)
15 _commit=1712231caf8886d73bd64964814793f19f6e1d70 # tags/2.46.3^0
16 source=("git+https://gitlab.gnome.org/GNOME/pangomm.git#commit=$_commit")
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 arch-meson pangomm build -D maintainer-mode=true
30 meson compile -C build
34 meson test -C build --print-errorlogs
38 depends+=(libsigc-2.0.so libglibmm-2.4.so libcairomm-1.0.so)
39 provides=(libpangomm-1.4.so)
41 meson install -C build --destdir "$pkgdir"
44 mkdir -p docs/usr/share
45 mv -t docs/usr/share "$pkgdir"/usr/share/{devhelp,doc}
48 package_pangomm-docs() {
49 pkgdesc+=" (documentation)"
53 mv -t "$pkgdir" docs/*
56 # vim:set sw=2 sts=-1 et: