archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pappl / trunk / PKGBUILD
blob7c1aad1c839afeca67f450df0b39b65fb755283e
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 pkgname=pappl
4 pkgver=1.3.2
5 pkgrel=1
6 pkgdesc="a simple C-based framework/library for developing CUPS Printer Applications"
7 arch=('x86_64')
8 url="https://www.msweet.org/pappl/"
9 license=('Apache' 'custom')
10 depends=('libcups' 'libjpeg-turbo' 'pam')
11 makedepends=('git')
12 source=(https://github.com/michaelrsweet/pappl/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz{,.sig})
13 sha256sums=('c3d8febb56367940dd4c26e794fc5014abe8cd6ff0a63d1ce9e2c9089ce361c5'
14             'SKIP')
15 validpgpkeys=('845464660B686AAB36540B6F999559A027815955') # "Michael R Sweet <michael.r.sweet@gmail.com>"
16 #validpgpkeys=('9086C3CDC66C3F563CF8F405BE67C75EC81F3244') # Michael R Sweet <msweet@msweet.org>
18 build() {
19   cd "$pkgname-$pkgver"
21   # The build system uses only DSOFLAGS but not LDFLAGS to build some libraries.
22   export DSOFLAGS=${LDFLAGS}
24   ./configure --prefix=/usr
25   make
28 check() {
29   cd "$pkgname-$pkgver"
30   #make check
32   # there's currently  no real test suite, 
33   # the tool is only useful outside the fakeroot envireonment - when packaging it crashes:
34   # testpappl: client.c:771: avahi_client_get_host_name_fqdn: Assertion `client' failed.
35   # /startdir/PKGBUILD: line 43:  1878 Aborted                 (core dumped) ./testsuite/testpappl
37   # run it later outside fakeroot!
38   #./testsuite/testpappl 
41 package() {
42   cd "$pkgname-$pkgver"
43   make DESTDIR="$pkgdir/" install
45   # install the testing tool
46   install -Dm755 testsuite/testpappl -t "$pkgdir"/usr/bin
47   # install docs
48   install -Dm644 doc/* -t "$pkgdir"/usr/share/doc/$pkgname
49   # add license + exception
50   install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,NOTICE}