archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-async-interrupt / trunk / PKGBUILD
blob0430fbd51415bd79fc1ddc23c4f007cdb1e0ac7a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Justin Davis (juster) <jrcd83@gmail.com>
4 pkgname=perl-async-interrupt
5 pkgver=1.26
6 pkgrel=4
7 pkgdesc='allow C/XS libraries to interrupt perl asynchronously'
8 arch=(x86_64)
9 license=(PerlArtistic GPL)
10 options=(!emptydirs)
11 depends=('perl-canary-stability' 'perl-common-sense')
12 url=https://metacpan.org/release/Async-Interrupt
13 source=("https://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Async-Interrupt-$pkgver.tar.gz")
14 sha512sums=('7fab1899e11064e1be292eb1c2e149278bfaab5087afcfa6898f9b6095278fa74ebab2114abd69ca0bfbd8028038cdd3df7953e14460c77194ccc7041b87f5c6')
16 build() {
17   cd Async-Interrupt-$pkgver
18   PERL_MM_USE_DEFAULT=1 perl Makefile.PL
19   make
22 check() {
23   cd Async-Interrupt-$pkgver
24   make test
27 package() {
28   cd Async-Interrupt-$pkgver
29   make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
30   find "$pkgdir" -name .packlist -o -name perllocal.pod -delete