archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-mail-authenticationresults / trunk / PKGBUILD
blobf23c2601ecc9bdd189ffa18f6993c3b69bfe133b
1 # Maintainer: Florian Pritz <bluewind@xinu.at>
3 pkgname=perl-mail-authenticationresults
4 pkgver=2.20230112
5 pkgrel=1
6 pkgdesc='Object Oriented Authentication-Results Headers'
7 arch=(any)
8 license=(PerlArtistic GPL)
9 options=(!emptydirs)
10 depends=('perl>=5.8' perl-clone perl-json)
11 checkdepends=(perl-test-exception)
12 url=https://metacpan.org/release/Mail-AuthenticationResults
13 source=("https://cpan.metacpan.org/authors/id/M/MB/MBRADSHAW/Mail-AuthenticationResults-$pkgver.tar.gz")
14 md5sums=(6a0c22bb56634bc0ff656a01e23b4674)
15 sha512sums=(78ea5067e2386ccbbe5bb9c86150c8255e6f735319968180a59c992fac35a918704792b2f18bf10c0568a41690044fbdb14b9d23e7829c178a42eb64126725fb)
16 _ddir="Mail-AuthenticationResults-$pkgver"
18 build()
20   cd "$srcdir/$_ddir"
21   export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
22   unset PERL5LIB PERL_MM_OPT
23   /usr/bin/perl Makefile.PL
24   make
27 check()
29   cd "$srcdir/$_ddir"
30   export PERL_MM_USE_DEFAULT=1
31   unset PERL5LIB
32   make test
35 package()
37   cd "$srcdir/$_ddir"
38   make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
41 # Local Variables:
42 # mode: shell-script
43 # sh-basic-offset: 2
44 # End:
45 # vim:set ts=2 sw=2 et: