archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-module-build / trunk / PKGBUILD
blob037b874055dac91827dd14d5e4de00af8ab029bf
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
3 # Contributor: Alan Young <harleypig@gmail.com>
5 pkgname=perl-module-build
6 pkgver=0.4232
7 pkgrel=2
8 pkgdesc="Build, test, and install Perl modules"
9 arch=('any')
10 url="https://search.cpan.org/dist/Module-Build"
11 license=('PerlArtistic' 'GPL')
12 depends=('perl' 'perl-inc-latest')
13 checkdepends=('perl-par-dist' 'perl-archive-zip')
14 options=('!emptydirs')
15 source=(https://search.cpan.org/CPAN/authors/id/L/LE/LEONT/Module-Build-$pkgver.tar.gz)
16 sha512sums=('f8ff0aa918e1627af59417eb3d6cf63df52c452195905596f5a88482fc094c31b1963b0215627826b1cd33fa74893cadce138e5fd705adc14d9968f586da333c')
18 build() {
19   cd Module-Build-$pkgver
20   perl Build.PL installdirs=vendor
21   perl Build
24 check() {
25   cd Module-Build-$pkgver
26   perl Build test
29 package() {
30   cd Module-Build-$pkgver
31   perl Build install destdir="$pkgdir"