1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Justin Davis (juster) <jrcd83@gmail.com>
4 pkgname=perl-mozilla-ca
7 pkgdesc="Mozilla's CA cert bundle in PEM format (using system CA store)"
9 license=('GPL2' 'LGPL2.1')
10 options=('!emptydirs')
11 depends=('perl' 'ca-certificates')
12 url='https://metacpan.org/release/Mozilla-CA'
13 source=("https://search.cpan.org/CPAN/authors/id/H/HA/HAARG/Mozilla-CA-$pkgver.tar.gz")
14 sha512sums=('c996576cf48c1c0691c5fdde6a029f713dfd4d3f2068754702c8015b90faaf119bd54d673d9ad7cfe0c2f33307b230a7b6282af1dccbcf8a01f1290d5bb9fe81')
18 # Use system CA store. Replacing the copy in the source tree so the test suite is actually run against it.
19 ln -sf /etc/ssl/certs/ca-certificates.crt lib/Mozilla/CA/cacert.pem
24 perl Makefile.PL INSTALLDIRS=vendor
35 make install DESTDIR="$pkgdir"
37 # Replace CA store here again because the symlink was installed as a file
38 ln -sf /etc/ssl/certs/ca-certificates.crt "$pkgdir"/usr/share/perl5/vendor_perl/Mozilla/CA/cacert.pem
41 # vim:set ts=2 sw=2 et: