archrelease: copy trunk to extra-x86_64
[arch-packages.git] / plasma-firewall / trunk / PKGBUILD
blob959d3dcaba2802a3b31b00f419db375f12acc835
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plasma-firewall
4 pkgver=5.27.5
5 _dirver=$(echo $pkgver | cut -d. -f1-3)
6 pkgrel=1
7 pkgdesc='Control Panel for your system firewall'
8 arch=(x86_64)
9 url='https://kde.org/plasma-desktop/'
10 license=(GPL LGPL)
11 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
12 depends=(systemsettings)
13 makedepends=(extra-cmake-modules)
14 optdepends=('iproute2: netstat backend'
15             'firewalld: firewalld backend'
16             'ufw: ufw backend')
17 groups=(plasma)
18 sha256sums=('e32c90aa52ec35d35fd04e04d00989f18d43ea1f7b244e53de7feb7745235b41'
19             'SKIP')
20 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
21               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
22               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
23               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
25 build() {
26   cmake -B build -S $pkgname-$pkgver \
27     -DLIBEXEC_INSTALL_DIR=lib
28   cmake --build build
31 package() {
32   DESTDIR="$pkgdir" cmake --install build