archrelease: copy trunk to extra-x86_64
[arch-packages.git] / plasma-integration / repos / extra-x86_64 / PKGBUILD
blob10dbd0b9988f54e423c38a36a7fccd99fd15daff
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=plasma-integration
5 pkgver=5.27.5
6 _dirver=$(echo $pkgver | cut -d. -f1-3)
7 pkgrel=1
8 pkgdesc='Qt Platform Theme integration plugins for the Plasma workspaces'
9 arch=(x86_64)
10 url='https://kde.org/plasma-desktop/'
11 license=(LGPL)
12 depends=(libxcursor noto-fonts ttf-hack qqc2-desktop-style perl)
13 makedepends=(extra-cmake-modules breeze plasma-wayland-protocols)
14 groups=(plasma)
15 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('8dedc5630828f0fb5912ca7cad9df5cde2492e17fd2956de6f514d43b4f89f7b'
17             'SKIP')
18 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
19               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
20               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
21               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DBUILD_TESTING=OFF
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build