archrelease: copy trunk to extra-x86_64
[arch-packages.git] / plasma-settings / trunk / PKGBUILD
blob84a4b878db2f4f002888e3c6df6c9f97dd574d30
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plasma-settings
4 pkgver=23.01.0
5 pkgrel=1
6 pkgdesc='Settings application for Plasma Mobile'
7 url='https://plasma-mobile.org/'
8 arch=(x86_64)
9 license=(GPL)
10 depends=(kirigami-addons networkmanager-qt modemmanager-qt plasma-framework)
11 makedepends=(extra-cmake-modules)
12 source=(https://download.kde.org/stable/plasma-mobile/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
13 sha256sums=('e786dd522969fea5be9f4e91ecfb8ccffc28127ba0de74f634aa9600bdfce03b'
14             'SKIP')
15 validpgpkeys=(39FFA93CAE9C6AFC212AD00202325448204E452A  # Carl Schwan <carl@carlschwan.eu>
16               0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D) # Bhushan Shah (mykolab address) <bshah@mykolab.com>
18 build() {
19   cmake -B build -S $pkgname-$pkgver
20   cmake --build build
23 package() {
24   DESTDIR="$pkgdir" cmake --install build