archrelease: copy trunk to extra-x86_64
[arch-packages.git] / plasma-systemmonitor / trunk / PKGBUILD
blob5d892bc07e53af61d599fd524fa2d4a43bfc0657
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plasma-systemmonitor
4 pkgver=5.27.5
5 _dirver=$(echo $pkgver | cut -d. -f1-3)
6 pkgrel=1
7 pkgdesc='An interface for monitoring system sensors, process information and other system resources'
8 arch=(x86_64)
9 url='https://kde.org/plasma-desktop/'
10 license=(GPL LGPL)
11 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
12 depends=(ksystemstats kitemmodels qqc2-desktop-style kquickcharts kdeclarative)
13 makedepends=(extra-cmake-modules)
14 groups=(plasma)
15 sha256sums=('82e551398f208270f543d5f91be6f3f3b27b1ce9f2c0e90263f29f8d238b2e34'
16             'SKIP')
17 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
18               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
19               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
20               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
22 build() {
23   cmake -B build -S $pkgname-$pkgver
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build