archrelease: copy trunk to extra-x86_64
[arch-packages.git] / plymouth-kcm / trunk / PKGBUILD
blob45af18c248cd3d17f3f84eb2b4808760f3fcf633
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plymouth-kcm
4 pkgver=5.27.5
5 _dirver=$(echo $pkgver | cut -d. -f1-3)
6 pkgrel=1
7 pkgdesc='KCM to manage the Plymouth (Boot) theme'
8 arch=(x86_64)
9 url='https://kde.org/plasma-desktop/'
10 license=(LGPL)
11 depends=(systemsettings plymouth)
12 makedepends=(extra-cmake-modules)
13 groups=(plasma)
14 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig}
15         https://invent.kde.org/plasma/plymouth-kcm/-/commit/49b4435b.patch)
16 sha256sums=('596249b9df646d388d93a80459ecdfd77d1fa3dc070aa0c7ddf2fef9719d0064'
17             'SKIP'
18             '67c9f7233720f72d3d4141255760c020c6d054271d632b40823921020a4cc2d6')
19 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
20               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
21               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
22               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
24 prepare() {
25   patch -d $pkgname-$pkgver -p1 < 49b4435b.patch # Run mkinitcpio instead of initramfs
28 build() {
29   cmake -B build -S $pkgname-$pkgver \
30     -DBUILD_TESTING=OFF
31   cmake --build build
34 package() {
35   DESTDIR="$pkgdir" cmake --install build