archrelease: copy trunk to extra-x86_64
[arch-packages.git] / polari / trunk / PKGBUILD
blob82dc3e59369e30eaa4601536c0595cfa52fde4ff
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=polari
4 pkgver=43.0
5 pkgrel=2
6 pkgdesc="An IRC Client for GNOME"
7 url="https://wiki.gnome.org/Apps/Polari"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(
11   gjs
12   gtk4
13   libadwaita
14   libsoup3
15   telepathy-glib
16   telepathy-idle
17   telepathy-logger
18   telepathy-mission-control
20 makedepends=(
21   appstream-glib
22   git
23   gobject-introspection
24   meson
25   yelp-tools
27 groups=(gnome-extra)
28 _commit=0cf049c1c5704cf5fa0a4b80194860e2c4e433a9  # tags/43.0^0
29 source=("git+https://gitlab.gnome.org/GNOME/polari.git#commit=$_commit")
30 b2sums=('SKIP')
32 pkgver() {
33   cd polari
34   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
37 prepare() {
38   cd polari
41 build() {
42   arch-meson polari build
43   meson compile -C build
46 check() {
47   meson test -C build --print-errorlogs
50 package() {
51   meson install -C build --destdir "$pkgdir"
54 # vim:set sw=2 sts=-1 et: