archrelease: copy trunk to extra-x86_64
[arch-packages.git] / polkit / trunk / PKGBUILD
bloba9062d250dff6078fe6889518432c9ec16184125
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=polkit
5 pkgver=122
6 pkgrel=1
7 pkgdesc="Application development toolkit for controlling system-wide privileges"
8 url="https://gitlab.freedesktop.org/polkit/polkit"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   duktape
13   expat
14   glib2
15   pam
16   systemd
18 makedepends=(
19   git
20   gobject-introspection
21   gtk-doc
22   meson
24 checkdepends=(python-dbusmock)
25 provides=(libpolkit-{agent,gobject}-1.so)
26 backup=(etc/pam.d/polkit-1)
27 _commit=da87c5698019897dd731bb2cbb54ebd9c9481f52  # tags/122
28 source=(
29   "git+https://gitlab.freedesktop.org/polkit/polkit.git#commit=$_commit"
31 b2sums=('SKIP')
33 pkgver() {
34   cd polkit
35   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
38 prepare() {
39   cd polkit
42 build() {
43   local meson_options=(
44     -D examples=true
45     -D gtk_doc=true
46     -D man=true
47     -D os_type=redhat
48     -D session_tracking=libsystemd-login
49     -D tests=true
50   )
52   arch-meson polkit build "${meson_options[@]}"
53   meson compile -C build
56 check() {
57   meson test -C build --print-errorlogs -t 3
60 package() {
61   meson install -C build --destdir "$pkgdir"
63   install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
65   install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
66 u polkitd 102 "PolicyKit daemon"
67 m polkitd proc
68 END
71 # vim:set sw=2 sts=-1 et: