archrelease: copy trunk to extra-x86_64
[arch-packages.git] / portaudio / trunk / PKGBUILD
blob9cbc17fdc7bb72c20b70ec12c586195774f62563
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Lukas Fleischer <lfleischer@archlinux.org>
3 # Contributor: Eric Belanger <eric@archlinux.org>
4 # Contributor: Darwin Bautista <djclue917@gmail.com>
5 # Contributor: Bob Finch <w9ya@qrparci.net>
7 pkgname=portaudio
8 pkgver=19.7.0
9 pkgrel=2
10 epoch=1
11 pkgdesc='A free, cross-platform, open source, audio I/O library.'
12 arch=(x86_64)
13 url="https://github.com/portaudio/portaudio/"
14 license=(MIT)
15 depends=(
16   gcc-libs
17   glibc
19 makedepends=(
20   alsa-lib
21   cmake
22   jack
24 provides=(
25   libportaudio.so
26   libportaudiocpp.so
28 source=($url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
29 sha512sums=('7e347a174109b661a685bcd617cc8fe00929c6fbf28f142fd7709a8ddbb9b5ed6e805be6647a44b4b9441b79e3474561de6f8e351b4ffc024952ed3e0e27ac1c')
30 b2sums=('db16882e97e60ab47b37c6d8851aa29e16e321531f3890f70390d89364aee2c1a9b42be09e7534f38d1c9ca48dd466b512874731049e42759a674571d6054220')
32 prepare() {
33   cd $pkgname-$pkgver
34   (
35    cd bindings/cpp
36    autoreconf -fiv
37   )
38   autoreconf -fiv
41 build() {
42   local configure_options=(
43     --prefix=/usr
44     --enable-cxx
45   )
47   cd $pkgname-$pkgver
48   ./configure "${configure_options[@]}"
49   # build breaks with multiple jobs when building C++ bindings:
50   # https://github.com/PortAudio/portaudio/issues/540
51   make -j1
54 package() {
55   depends+=(
56     alsa-lib libasound.so
57     jack libjack.so
58   )
60   cd $pkgname-$pkgver
61   make DESTDIR="$pkgdir" install
62   install -vDm 644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
63   install -vDm 644 README.* -t "$pkgdir/usr/share/doc/$pkgname/"