archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pptpclient / trunk / PKGBUILD
blob63b49193621c18ea579b7f5d0696e44544dc25b5
1 # Maintainer:
2 # Contributor: Daniel Isenmann <daniel @ archlinux.org>
3 # Contributor: Mark Nikkel <mnikkel@gmail.com>
5 pkgname=pptpclient
6 pkgver=1.10.0
7 pkgrel=3
8 pkgdesc="Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP."
9 arch=('x86_64')
10 url="http://pptpclient.sourceforge.net/"
11 license=('GPL')
12 depends=('ppp' 'iproute2' 'perl')
13 backup=('etc/ppp/options.pptp')
14 source=("https://downloads.sourceforge.net/sourceforge/pptpclient/pptp-$pkgver.tar.gz")
15 sha256sums=('82492db8e487ce73b182ee7f444251d20c44f5c26d6e96c553ec7093aefb5af4')
17 prepare() {
18   cd pptp-$pkgver
20   # use our CFLAGS and LDFLAGS
21   sed -i -e "/CFLAGS  =/ c\CFLAGS = ${CFLAGS}" Makefile
22   sed -i -e "/LDFLAGS =/ c\LDFLAGS = ${LDFLAGS}" Makefile
24   # adjust ip path
25   sed -i 's#/bin/ip#/usr/bin/ip#' routing.c
27   # put binaries in /usr/bin
28   sed -i "/BINDIR/s#/sbin#/bin#" Makefile
31 build() {
32   cd pptp-$pkgver
33   make 
36 package() {
37   cd pptp-$pkgver
38   make DESTDIR="$pkgdir" install