1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
8 pkgdesc="Python bindings for D-Bus AT-SPI"
9 url="https://wiki.linuxfoundation.org/accessibility/atk/at-spi/at-spi_on_d-bus"
12 depends=(python-gobject at-spi2-core)
14 _commit=c9cb2a2289a6eb1fb95b66c25d5351bfea54c47e # tags/PYATSPI_2_46_0^0
15 source=("git+https://gitlab.gnome.org/GNOME/pyatspi2.git#commit=$_commit")
20 git describe --tags | sed 's/^PYATSPI_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
25 NOCONFIGURE=1 ./autogen.sh
30 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
31 --with-python=/usr/bin/python
35 package_python-atspi() {
37 make DESTDIR="$pkgdir" install
40 # vim:set sw=2 sts=-1 et: