1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
5 pkgname=(shiboken6 pyside6 pyside6-tools)
11 url='https://www.qt.io'
13 makedepends=(cmake ninja clang llvm python-setuptools vulkan-headers python-numpy
14 qt6-tools qt6-svg qt6-3d qt6-scxml qt6-datavis3d qt6-charts qt6-multimedia qt6-quick3d
15 qt6-location qt6-positioning qt6-networkauth qt6-remoteobjects qt6-sensors qt6-serialbus qt6-serialport
16 qt6-connectivity qt6-webchannel qt6-webengine qt6-websockets qt6-shadertools qt6-speech qt6-httpserver)
17 _pkgfn=pyside-setup-everywhere-src-$_qtver
18 source=(https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-$pkgver-src/${_pkgfn}.tar.xz
19 designer-plugin-install-dir.patch)
20 sha256sums=('6ef53b29127267e381917e6f9399ce760edc0644cd5831988b1de72c9d583ab4'
21 '66e895e07d5b01c64a94092353854c946fd7fc445b6181068dca290b5a3887e0')
25 patch -d $_pkgfn -p1 < designer-plugin-install-dir.patch # Fix designer plugin install dir
29 cmake -B build -S $_pkgfn -G Ninja \
30 -DCMAKE_INSTALL_PREFIX=/usr \
31 -DCMAKE_BUILD_TYPE=None \
34 PYTHONPATH="$PWD"/build/sources \
39 pkgdesc='Generates bindings for C++ libraries using CPython source code'
40 depends=(clang=$_clangver llvm libxslt qt6-base)
41 optdepends=('python: Python bindings')
43 DESTDIR="$pkgdir" cmake --install build/sources/shiboken6
46 export PATH="/usr/lib/qt6/bin:$PATH"
47 export SETUPTOOLS_USE_DISTUTILS=stdlib
49 python setup.py egg_info --build-type=shiboken6
50 python setup.py egg_info --build-type=shiboken6-generator
51 _pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
52 cp -r shiboken6*.egg-info "$pkgdir"/$_pythonpath
56 pkgdesc='Enables the use of Qt6 APIs in Python applications'
57 depends=(qt6-declarative shiboken6)
58 optdepends=('qt6-tools: QtHelp, QtUiTools bindings'
59 'qt6-svg: QtSvg bindings'
60 'qt6-3d: Qt3D bindings'
61 'qt6-quick3d: QtQuick3D bindings'
62 'qt6-scxml: QtScxml bindings'
63 'qt6-datavis3d: QtDataVisualization bindings'
64 'qt6-charts: QtCharts bindings'
65 'qt6-httpserver: QtHttpServer bindings'
66 'qt6-location: QtLocation bindings'
67 'qt6-multimedia: QtMultimedia bindings'
68 'qt6-serialbus: QtSerialBus bindings'
69 'qt6-serialport: QtSerialPort bindings'
70 'qt6-speech: QtTextToSpeech bindings'
71 'qt6-webengine: QtWebEngine bindings'
72 'qt6-remoteobjects: QtRemoteObjects bindings'
73 'qt6-sensors: QtSensors bindings'
74 'qt6-websockets: QtWebSockets bindings'
75 'qt6-networkauth: QtNetworkAuth bindings')
77 DESTDIR="$pkgdir" cmake --install build/sources/pyside6
80 export PATH="/usr/lib/qt6/bin:$PATH"
82 python setup.py egg_info --build-type=pyside6
83 _pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
84 cp -r PySide6.egg-info "$pkgdir"/$_pythonpath
87 install -Dm644 "$srcdir"/build/sources/pyside6/PySide6/*.pyi -t "$pkgdir"/usr/lib/python*/site-packages/PySide6
90 package_pyside6-tools() {
91 pkgdesc='Tools for pyside6'
94 DESTDIR="$pkgdir" cmake --install build/sources/pyside-tools