archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-attrs / trunk / PKGBUILD
blobc46379e88487a89ec8ec33f7b52b5a6ae164d9b9
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-attrs
4 pkgver=22.2.0
5 pkgrel=3
6 pkgdesc="Attributes without boilerplate."
7 arch=('any')
8 license=('MIT')
9 url="https://www.attrs.org"
10 depends=('python')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest' 'python-cloudpickle' 'python-hypothesis' 'python-zope-interface')
13 source=("https://pypi.io/packages/source/a/attrs/attrs-$pkgver.tar.gz")
14 sha512sums=('a7707fb11e21cddd2b25c94c9859dc8306745f0256237493a4ad818ffaf005d1c1e84d55d07fce14eaea18fde4994363227286df2751523e1fe4ef6623562a20')
16 build() {
17   cd attrs-$pkgver
18   python setup.py build
21 check() {
22   cd attrs-$pkgver
23   PYTHONPATH=build/lib pytest
26 package() {
27   cd attrs-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
29   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/