archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-idna / trunk / PKGBUILD
blob5adfce395a2b2877d04c74e47d2219b9d0ab821a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-idna
4 pkgver=3.4
5 pkgrel=3
6 pkgdesc="Internationalized Domain Names in Applications (IDNA)"
7 arch=('any')
8 license=('BSD')
9 url="https://github.com/kjd/idna"
10 depends=('python')
11 makedepends=('python-build' 'python-installer' 'python-flit-core')
12 checkdepends=('python-pytest')
13 source=("https://pypi.io/packages/source/i/idna/idna-$pkgver.tar.gz")
14 sha512sums=('4060a9304c9bac04efdd0b97ec8f5aeb7e17417e767bf51c5dfc26605edad25ab67456cf6f6a3c5a9f32b8247e46f6343edfd8a6ffbcd6d1075c71e66d089d6a')
16 build() {
17    cd idna-$pkgver
18    python -m build --no-isolation --wheel
21 check() {
22    cd idna-$pkgver
23    pytest
26 package() {
27    cd idna-$pkgver
28    python -m installer --destdir="$pkgdir" dist/*.whl
29    install -Dm644 LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname/