archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-incremental / trunk / PKGBUILD
blob9b914ad51f0e5c7397e9615a0dbd03af9921c8ad
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-incremental
4 pkgver=22.10.0
5 pkgrel=3
6 pkgdesc='A small library that versions your Python projects'
7 arch=('any')
8 license=('MIT')
9 depends=('python-click' 'python-setuptools' 'python-twisted')
10 url='https://github.com/hawkowl/incremental'
11 checkdepends=('python-pytest')
12 source=("https://github.com/hawkowl/incremental/archive/incremental-$pkgver.tar.gz")
13 sha512sums=('fbc0b123038341a788789aa513c93dfa08592881ea89aafebdd5b21917a9888f7a7d54d7765c105eb362559391ef45f15d8ef98278b0e75c84fce7d83febf5f0')
15 build() {
16   cd incremental-incremental-$pkgver
17   python setup.py build
20 check() {
21   cd incremental-incremental-$pkgver
22   pytest
25 package() {
26   cd incremental-incremental-$pkgver
27   python setup.py install --root="$pkgdir" --optimize=1
28   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
31 # vim:set ts=2 sw=2 et: