archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-nspektr / trunk / PKGBUILD
blob97658240ac4c130723a132e37c825b0002095efd
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Achmad Fathoni<fathoni.id(at)gmail.com>
4 pkgname=python-nspektr
5 pkgver=0.4.0
6 pkgrel=3
7 pkgdesc="A distribution package dependency inspector"
8 arch=('any')
9 url="https://github.com/jaraco/nspektr"
10 license=('MIT')
11 depends=('python-jaraco.context' 'python-jaraco.functools' 'python-more-itertools'
12          'python-packaging')
13 makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm')
14 checkdepends=('python-pytest-enabler' 'python-pytest-mypy')
15 source=("https://github.com/jaraco/nspektr/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
16 sha256sums=('b29969de2a4975d154c43fd09ae7aa439b7b64732d1ab1964658d8ce9f8359ee')
18 export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
20 build() {
21   cd nspektr-$pkgver
22   python -m build -wn
25 check() {
26   cd nspektr-$pkgver
27   python -m pytest
30 package() {
31   cd nspektr-$pkgver
32   python -m installer --destdir="$pkgdir" dist/*.whl
33   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/