archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-platformdirs / repos / extra-any / PKGBUILD
blob73365bf69db53f22650b8c9bb6a1c5745c356510
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Tobias Roettger <toroettg@gmail.com>
4 pkgname=python-platformdirs
5 pkgver=3.5.1
6 pkgrel=1
7 pkgdesc='A small Python module for determining appropriate platform-specific dirs, e.g. a "user data dir"'
8 arch=('any')
9 url="https://github.com/platformdirs/platformdirs"
10 license=('MIT')
11 depends=('python-typing_extensions')
12 makedepends=('python-build' 'python-installer' 'python-hatchling' 'python-hatch-vcs')
13 checkdepends=('python-pytest-mock' 'python-appdirs')
14 source=("https://pypi.io/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz")
15 sha512sums=('e3aa38bc943f9dc709dfaa3c6fe9e11f3b33d4263d1d41f7349d9926db2e41a36dd43c74ea2175ad89b107601f2dffded0f45e7703b9cb8ca9739945dee3c6fb')
17 build() {
18   cd platformdirs-$pkgver
19   python -m build --wheel --no-isolation
22 check() {
23   cd platformdirs-$pkgver
24   PYTHONPATH="$PWD"/src pytest
27 package() {
28   cd platformdirs-$pkgver
29   python -m installer --destdir="$pkgdir/" dist/*.whl
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
33 # vim:set ts=2 sw=2 et: