1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Troy C < rstrox -ta yahoo -tod com >
7 pkgdesc="A Python module for decorators, wrappers and monkey patching"
9 url="https://pypi.python.org/pypi/wrapt"
12 makedepends=('python-setuptools')
13 checkdepends=('python-pytest')
14 source=("https://github.com/GrahamDumpleton/wrapt/archive/$pkgver/$pkgname-$pkgver.tar.gz")
15 sha512sums=('c67e99eb29afeefb2512fb545cd180b8e96f69235d6281edebe62ea5e411188a904a7e683afdda2d6a86cf8b7fd74f79a3c3bec04e19a7c5ef347729bb43f94c')
24 PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-311" py.test
29 python setup.py install --root="$pkgdir" --optimize=1
30 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE