archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qqc2-desktop-style / trunk / PKGBUILD
blob7196a703e3911f0ac868dcc44ecc7243e60d87c1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=qqc2-desktop-style
4 pkgver=5.106.0
5 pkgrel=1
6 pkgdesc='A style for Qt Quick Controls 2 to make it follow your desktop theme'
7 arch=(x86_64)
8 url='https://community.kde.org/Frameworks'
9 license=(LGPL)
10 groups=(kf5)
11 depends=(kirigami2 kiconthemes sonnet)
12 makedepends=(extra-cmake-modules)
13 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('daaefed5ad4edeb262c23922a2d766854d9d3ff1889176a812e6a09af39e9db1'
15             'SKIP')
16 validpgpkeys=('53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB') # David Faure <faure@kde.org>
18 build() {
19   cmake -B build -S $pkgname-$pkgver \
20     -DBUILD_TESTING=OFF
21   cmake --build build
24 package() {
25   DESTDIR="$pkgdir" cmake --install build