archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-location / repos / extra-x86_64 / PKGBUILD
blobba65159ead31913fddc063b307841c5fff926d0b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=qt5-location
5 _basever=5.15.9
6 pkgver=5.15.9+kde+r4
7 pkgrel=1
8 _commit=2a8a48e9101236f118c2c4f0d79fae9c9d7b3f2a
9 arch=('x86_64')
10 url='https://www.qt.io'
11 license=('GPL3' 'LGPL3' 'FDL' 'custom')
12 pkgdesc='Provides access to position, satellite and area monitoring classes'
13 depends=('qt5-declarative')
14 makedepends=('git')
15 groups=('qt' 'qt5')
16 _pkgfqn=${pkgname/5-/}
17 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
18         git+https://invent.kde.org/qt/qt/qtlocation-mapboxgl.git)
19 sha256sums=('SKIP'
20             'SKIP')
22 pkgver() {
23   cd $_pkgfqn
24   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit` | sed -e 's|+kde+r0||'
27 prepare() {
28   mkdir -p build
30   cd ${_pkgfqn}
31   git submodule init
32   git submodule set-url src/3rdparty/mapbox-gl-native "$srcdir"/qtlocation-mapboxgl
33   git -c protocol.file.allow=always submodule update
36 build() {
37   cd build
39   qmake ../${_pkgfqn}
40   make
43 package() {
44   cd build
45   make INSTALL_ROOT="$pkgdir" install
47   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
48   find "$pkgdir/usr/lib" -type f -name '*.prl' \
49     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
51   install -d "$pkgdir"/usr/share/licenses
52   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}