archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-datavis3d / repos / extra-x86_64 / PKGBUILD
blob36ae8078cd84a085e1640e61a0e473024f3534ea
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-datavis3d
5 _qtver=6.5.0
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Qt6 Data Visualization module'
12 depends=(qt6-base)
13 makedepends=(cmake ninja qt6-declarative)
14 optdepends=('qt6-declarative: QML bindings')
15 groups=(qt6)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('d48ac17717e7ae7d8251c660a2b1ec97884c3d6a411f0ab901168c5683a9816b')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja \
22     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname