1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Helps you create viable mapping solutions using the data available from some of the popular location services'
12 depends=(qt6-declarative qt6-positioning)
13 makedepends=(cmake ninja qt6-shadertools)
15 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
16 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
17 sha256sums=('0ebfa7504958af45f7311e1a3d4f7a4eb395d937705f1e5475652c5f5a28c30c')
20 cmake -B build -S $_pkgfn -G Ninja \
21 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
26 DESTDIR="$pkgdir" cmake --install build
28 install -d "$pkgdir"/usr/share/licenses
29 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname