archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-location / repos / extra-x86_64 / PKGBUILD
blob21661a3c73b94bef444529d4c29cf64dd71729f1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-location
5 _qtver=6.5.0
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Helps you create viable mapping solutions using the data available from some of the popular location services'
12 depends=(qt6-declarative qt6-positioning)
13 makedepends=(cmake ninja qt6-shadertools)
14 groups=(qt6)
15 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
16 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
17 sha256sums=('0ebfa7504958af45f7311e1a3d4f7a4eb395d937705f1e5475652c5f5a28c30c')
19 build() {
20   cmake -B build -S $_pkgfn -G Ninja \
21     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build
28   install -d "$pkgdir"/usr/share/licenses
29   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname