archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-networkauth / repos / extra-x86_64 / PKGBUILD
blobe1773eab98c3010096a355143770d65336f678e9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-networkauth
6 _qtver=6.5.0
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Network authentication module'
13 depends=(qt6-base)
14 makedepends=(cmake ninja)
15 groups=(qt6)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('dbcc522ab2136ebe6c9be5c7f156a3bcefa92cd19a462e33a00e94068a24413e')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja \
22     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname