1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-remoteobjects
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Inter-process communication (IPC) module developed for Qt'
13 makedepends=(cmake ninja qt6-declarative)
14 optdepends=('qt6-declarative: QML bindings')
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('ff40b6e7afa84e44190d3b6357462569525b1e1fb0e8bfd8de16a8680825c2ae')
21 cmake -B build -S $_pkgfn -G Ninja \
22 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
27 DESTDIR="$pkgdir" cmake --install build
29 install -d "$pkgdir"/usr/share/licenses
30 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname