1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Classes for displaying the contents of SVG files'
14 makedepends=(cmake ninja)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('64ca7e61f44d51e28bcbb4e0509299b53a9a7e38879e00a7fe91643196067a4f')
21 cmake -B build -S $_pkgfn -G Ninja \
22 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
27 DESTDIR="$pkgdir" cmake --install build
29 install -d "$pkgdir"/usr/share/licenses
30 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname